home *** CD-ROM | disk | FTP | other *** search
/ Chip 2007 January, February, March & April / Chip-Cover-CD-2007-02.iso / Pakiet bezpieczenstwa / mini Pentoo LiveCD 2006.1 / mpentoo-2006.1.iso / livecd.squashfs / var / db / pkg / gnome-base / gnome-libs-1.4.2 / gnome-libs-1.4.2.ebuild < prev    next >
Text File  |  2005-10-20  |  2KB  |  97 lines

  1. # Copyright 1999-2005 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. # $Header: /var/cvsroot/gentoo-x86/gnome-base/gnome-libs/gnome-libs-1.4.2.ebuild,v 1.30 2005/05/29 22:47:14 halcy0n Exp $
  4.  
  5. inherit eutils libtool multilib
  6.  
  7. DESCRIPTION="GNOME Core Libraries"
  8. HOMEPAGE="http://www.gnome.org/"
  9. SRC_URI="ftp://ftp.gnome.org/pub/GNOME/sources/${PN}/1.4/${P}.tar.bz2"
  10.  
  11. LICENSE="GPL-2"
  12. SLOT="1"
  13. KEYWORDS="alpha amd64 arm hppa ia64 mips ppc ppc64 sparc x86"
  14. IUSE="doc nls kde"
  15.  
  16. RDEPEND=">=media-libs/imlib-1.9.10
  17.     >=media-sound/esound-0.2.23
  18.     =gnome-base/orbit-0*
  19.     =x11-libs/gtk+-1.2*
  20.     <=sys-libs/db-2
  21.     doc? ( app-text/docbook-sgml
  22.         dev-util/gtk-doc )"
  23. DEPEND="${RDEPEND}
  24.     nls? ( >=sys-devel/gettext-0.10.40
  25.         >=dev-util/intltool-0.11 )"
  26.  
  27. src_unpack() {
  28.     unpack ${A}
  29.     cd "${S}"
  30.     epatch "${FILESDIR}"/${P}-m4.patch
  31.     # Correct problems with documentation. See bug #44439.
  32.     epatch "${FILESDIR}"/${P}-gtkdoc_fixes.patch
  33.     # Fix compilation with GCC4 ; bug #94321
  34.     epatch "${FILESDIR}"/${P}-gcc4.patch
  35. }
  36.  
  37. src_compile() {
  38.     CFLAGS="$CFLAGS -I/usr/include/db1"
  39.  
  40.     # On alpha with 3.3.2 compilers we need to restrict options to
  41.     # make this actually build.  I don't know what the upper limit is
  42.     # but the following works (and who really cares about
  43.     # gnome-libs-1.4.x performance)
  44.     # (12 Nov 2003 agriffis)
  45.     if use alpha; then
  46.         # hopefully this overrides whatever is earlier on the line
  47.         # since working out the replacements would be a pain
  48.         CFLAGS="${CFLAGS} -O0 -mcpu=ev4"
  49.     fi
  50.  
  51.     local myconf
  52.  
  53.     use nls || myconf="${myconf} --disable-nls"
  54.     use kde && myconf="${myconf} --with-kde-datadir=/usr/share"
  55.     use doc || myconf="${myconf} --disable-gtk-doc"
  56.  
  57.     # libtoolize
  58.     elibtoolize
  59.  
  60.     ./configure --host=${CHOST} \
  61.         --prefix=/usr \
  62.         --libdir=/usr/$(get_libdir) \
  63.         --mandir=/usr/share/man \
  64.         --infodir=/usr/share/info \
  65.         --sysconfdir=/etc \
  66.         --localstatedir=/var/lib \
  67.         --enable-prefer-db1 \
  68.         ${myconf} || die
  69.  
  70.     emake || die
  71.  
  72.     #do the docs (maby add a use variable or put in seperate
  73.     #ebuild since it is mostly developer docs?)
  74.     if use doc
  75.     then
  76.         cd ${S}/devel-docs
  77.         emake || die
  78.         cd ${S}
  79.     fi
  80. }
  81.  
  82. src_install() {
  83.     make prefix=${D}/usr \
  84.         libdir=${D}/usr/$(get_libdir) \
  85.         mandir=${D}/usr/share/man \
  86.         infodir=${D}/usr/share/info \
  87.         sysconfdir=${D}/etc \
  88.         localstatedir=${D}/var/lib \
  89.         docdir=${D}/usr/share/doc/${P} \
  90.         HTML_DIR=${D}/usr/share/gnome/html \
  91.         install || die
  92.  
  93.     rm ${D}/usr/share/gtkrc*
  94.  
  95.     dodoc AUTHORS ChangeLog README NEWS HACKING
  96. }
  97.